WordPress Plugin “The plugin does not have a valid header”

June 25, 2009

I use an excellent plugin to display my Last.fm recently listened to tracks.  You can find the plugin here.  After the upgrade to WP 2.8 I kept getting this error when trying to activate the plugin “The plugin does not have a valid header.”  After trying a few different things I ran into this post that actually makes sense.  Ultimately, if your plugin is contained within a two folders it will be a problem.  For example, plugins\lastfm-records\last.fm\ will create a problem, you need to remove the lastfm-records folder and keep everything within last.fm.

 

~david

tags:
posted in WordPress by dmacias

Follow comments via the RSS Feed | Leave a comment | Trackback URL

5 Comments to "WordPress Plugin “The plugin does not have a valid header”"

  1. Jeroen wrote:

    Thanks for using my plugin, David. As you probably know, the problem has been fixed in the current version.

  2. dmacias wrote:

    Jeroen,

    I did notice that and I’ll update my post, by the way since I upgraded the plugin has stopped working, any thoughts? I also posted this question on your website.

    david

  3. Richard Feraro wrote:

    Check my explanation of this error:
    http://mysillypointofview.wordpress.com/2010/05/27/fix-the-plugin-does-not-have-a-valid-header-error/

  4. dmacias wrote:

    Richard,

    Thank you for your post, but your explanation is exactly the same as mine and to be honest it’s way too wordy. Regardless, I appreciate you helping people out.

    david

  5. Neil Mani wrote:

    hey! thanks for the help. now the has stopped but i don’t know why still the plugin is not working, though it’s showing up in the plugin area and i have already activated it……..

Leave Your Comment

 
Powered by Wordpress and MySQL. Theme by Shlomi Noach, openark.org